The tweets shown in my sidebar are not the most recent

Started by edmullen, July 26, 2011, 06:16:36 PM

previous topic - next topic
Go Down

edmullen

July 26, 2011, 06:16:36 PM Last Edit: August 02, 2013, 05:03:26 PM by Xhanch Studio
Instead, they seem to be the tweets that existed just before installing the code. It does not seem to refresh.

I am using the PHP code in a non-dynamic sidebar.

Xhanch Studio

July 27, 2011, 06:45:58 PM #1 Last Edit: August 02, 2013, 05:03:37 PM by Xhanch Studio
First of all, make sure you are using the latest version.

What method you use to display the widget (whether via widget, php code or short code) would be no problem.
The possible causes are:

  • Long import interval (see your configuration)

  • Cache period (see your configuration)

  • Somehow your server fails or cannot connect to Twitter to get new tweets



Btw, you can set the import interval and cache period to 0 and visit your website by adding ?xmt_debug_show to the URL.
You will find debug logs that may show what goes wrong.
Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

edmullen

Thanks. The cache seemed to work, but not right away. It didn't work right after I cleared the cache and changed the frequency, but it worked after a while.

Xhanch Studio

How long did you set the Cache Expiry and Import Interval?
Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

edmullen

I disabled cache (but changed the expiration to 0 anyway) and I set it to load tweets every 20 minutes.

Thanks again.

markhdavis

My feed is not updating. I've cleared the cache, and click get new tweets.... No change.

Suggestions, please?

The widget is visible at www.blinkassociates.com

Thanks in advance.

Xhanch Studio

Quote from: markhdavis on July 05, 2013, 04:55:41 PM
My feed is not updating. I've cleared the cache, and click get new tweets.... No change.
Suggestions, please?


Looks like you have solved your issue
Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

markhdavis

Yes I guess so. I hadn't noticed. I reset the codes to my Twitter app (may not have the lingo right, it's not in front of me). However, it took some time, at least hours, to start working again.

fcvolunteer

I've been using the plugin successfully but for the past two weeks I can't get any new tweets to load. Here's what I've tried:

  • clearing cache

  • clicking load new tweets

  • disconnecting from Twitter and reinserting authentication info.

  • viewing page in private browser/incognito window to see if cache was the problem



I'm at a loss. Any ideas?

Xhanch Studio

Quote from: fcvolunteer on August 01, 2013, 04:28:16 AM
I've been using the plugin successfully but for the past two weeks I can't get any new tweets to load.


Check possible causes mentioned above
Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

fcvolunteer

I did check them, before posting.

   Import interval = 0
   Cache Expiry = 0
 
   Debug Results =
- XMT: Starting to generate output -
- XMT: Import Tweets - Start - Exec time - 0 s -
- XMT: This application is not allowed to access or delete your direct messages (Code: 93) -
- XMT: Import Tweets - Finished - Exec time - 2 s -
- XMT: Get Tweets - Start - Exec time - 2 s -
- XMT: Get Tweets - Finished - Exec time - 2 s -
- XMT: Build Body - Start - Exec time - 2 s -
- XMT: Build header - Start - Exec time - 2 s -
- XMT: Build header - Finished - Exec time - 2 s -
- XMT: Build Body - Finished - Exec time - 2 s -
- XMT: Finished - Exec time - 2 s -

Go Up