No tweet posted to Twitter when a page/post is published

Started by Xhanch Studio, April 17, 2011, 05:02:54 AM

previous topic - next topic
Go Down

Xhanch Studio

A question from Michael Cantrell via contact form

QuoteI am using the plug in for Worpress to post to twitter when I submit my blog post.  I upgraded recently and it worked great for a couple weeks and now it stopped.  I had this same issue before the upgrade.  I love your plug-in.  Let me know if there is something I need to do to get it to work again.  Thanks.


Make sure that:

  • Advanced Features enabled by clicking Sign it with Twitter button

  • Post a tweet as you publish a new page/post under Advanced Features is ticked

  • Auto tweet layout under Advanced Features is not empty (If it empty, you can set it to New post: @title - @url)

Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

maurice14

Dear all,

I have upgraded to My Twitter version 2.6.7, and now I have the following issue: when a new post is made to my website, My Twitter does not automatically post a tweet to Twitter. The options 'post a tweet as you publish a new post' has been checked, and the auto tweet layout (post) has been set to '@title @url @summary'
The connection to Twitter does work: if I go to 'Post a tweet', type some data, and then click 'Post', Xhanch My Twitter is correctly posting the tweet to Twitter.
I'm using Wordpress version 3.2.1

Any help is welcome, I really like My Twitter and would like to continue using it.
Many thanks in advance

Xhanch Studio

Quote from: maurice14 on January 06, 2012, 02:52:50 PM
Dear all,

I have upgraded to My Twitter version 2.6.7, and now I have the following issue: when a new post is made to my website, My Twitter does not automatically post a tweet to Twitter. The options 'post a tweet as you publish a new post' has been checked, and the auto tweet layout (post) has been set to '@title @url @summary'
The connection to Twitter does work: if I go to 'Post a tweet', type some data, and then click 'Post', Xhanch My Twitter is correctly posting the tweet to Twitter.
I'm using Wordpress version 3.2.1

Any help is welcome, I really like My Twitter and would like to continue using it.
Many thanks in advance


Well, that's strange.
I just retest this feature and it works fine.

Some possibles causes I can think of:

  • The tweet content exceed 140 characters especially since you include your post summary

  • Temporary problem when connecting to Twitter to post a tweet

Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

maurice14


Thank you for your answer. I've found out that it might be related to the MySQL database: the 3 tables for My Twitter are not created back when I rename the tables, uninstall My Twitter and the install My Twitter again.
Would it be possible to post the SQL queries (for use in MySQL Workbench, I do not have PHPMyadmin installed) to create these 3 tables (wp_xmt_acc, wp_xmt_ath and wp_xmt_twt) again?
I think this will solve my issue.

Thank you in advance

Xhanch Studio

January 28, 2012, 12:29:47 PM #4 Last Edit: January 28, 2012, 12:31:58 PM by Xhanch Studio
Quote from: maurice14 on January 20, 2012, 03:26:10 PM

Thank you for your answer. I've found out that it might be related to the MySQL database: the 3 tables for My Twitter are not created back when I rename the tables, uninstall My Twitter and the install My Twitter again.
Would it be possible to post the SQL queries (for use in MySQL Workbench, I do not have PHPMyadmin installed) to create these 3 tables (wp_xmt_acc, wp_xmt_ath and wp_xmt_twt) again?
I think this will solve my issue.

Thank you in advance


You can add these codes as the first lines in xhanch-my-twitter/installer.php
Code Select
<?php 
    
if(isset($_GET['xmt-reinstall']))
        
update_option('xmt_vsn''');
?>

To reinstall, access your website via this URL
Quotehttp://[your-domain]/?xmt-reinstall=1


Don't forget to remove those codes when your issue is solved.
Best Regards,
Susanto B.Sc
----------------------------------------------------------------------------
Web development services, WordPress plugin and theme development, PSD to XHTML conversion - http://xhanch.com
Read free manga online - http://authrone.com

maurice14

Many thanks for your reply. The 3 tables are created and the profile succesfully connects to Twitter. I have another issue though: posting directly from the website (logged in as a user) works fine: My Twitter posts succesfully to Twitter.
However, when using a desktop blogging program, I can post to the blog but My Twitter does not post a tweet to Twitter.
Any ideas/suggestions to resolve this are most welcome.

Thanks and kind regards
Maurice

GrumpyTrucker

Hi,

I installed My Twitter yesterday and all was well. Today however I found that the tweets were no longer being posted to Twitter for new/updated posts. I tried checking the settings (that Advanced was set, and that the formatting was correct) and all was OK. As a last resort I deactivated and deleted My Twitter, then deleted the database tables. However, on reinstalling the database tables are not recreated. I have seen a similar post on this subject where it is suggested to add
Code Select
<?php 
    
if(isset($_GET['xmt-reinstall']))
        
update_option('xmt_vsn''');
?>


to the start of installer.php then access the site via
Code Select
http://[mydomain]/?xmt-reinstall=1

I have tried this and the database tables are still not being recreated. Any help you can give?

Thanks

GrumpyTrucker

OK, further info.

I finally managed to get the database tables to recreate but for some reason my entire site 'died'. No idea if it was related to constantly deleting/installing the plugin or just coincidental (website stats were showing premature ending of script on index.php) but either way it died. So, I exported the database tables for all the content and removed the entire Wordpress installation. I then reinstalled Wordpress and imported my mySQL database tables into the new database. I've now got all my content back, My Twitter installed and I can access all its settings and add it to my sidebar in the Widgets section.

Problem? Now it won't show on my page at all. I've got in the sidebar in Widgets, with a profile selected, but is not present on the blogpage although the rest of the sidebar is. So , I've just tried deactivating and reactivating it again. This time I get the Wordpress error:

QuoteThe plugin generated 1 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.


What can be causing this one now?

GrumpyTrucker

It's back. Finally. I looked at the post on the 'missing from sidebar' issue but none of the suggestions helped. Another couple of deactivations/deletions/reinstalls and it all came back. Gonna try not to break it again.

Any idea why it may occasionally stop posting tweets, which is what started this originally? If it helps, the 'tweet box' displayed when logged in as admin would work, it was just the auto tweets on new/updated posts that weren't.

Go Up